Minimum Window Width Required to View Content

Home Forums Automattic Newsy Minimum Window Width Required to View Content

Viewing 20 posts - 1 through 20 (of 27 total)
  • Author
    Posts
  • #162624 Resolve

    XOR LX

    Hi.

    I have recently purchased Newsy as my new Theme.

    I have noticed that the viewability of post content seems to be affected by changes in the zoom level in my browser. Readers have also complained that certain content is not visible.

    I have just finished an online chat with WordPress support who recommended that I posted here, saying that “it [newsy] doesn’t look like it is a responsive theme which means I think it does look for a minimum width of a window to see all the content”.

    Is this correct? Can this be resolved? Why is the issue intermittent? My previous Theme, which was free, did not suffer from this problem.

    Strangely, the problem does not seem to occur all the time, and I have not documented the precise circumstances surrounding when it does happen.

    Can anyone help with this, please?

    Apologies for the lack of details, and many thanks in advance.

    Regards

    The blog I need help with is excelxor.com
    #162625

    Kathryn P.
    Happiness Engineer

    Newsy is designed for screens at least 978px wide. At smaller screen sizes, viewers may have to zoom or scroll to read all the content.

    As you’ve been told during your chat, Newsy is not a responsive theme, so it doesn’t adapt automatically to fit smaller screen sizes. You can learn more here about the different types of website layouts:

    http://en.support.wordpress.com/themes/theme-layouts/

    If you’d like to keep this theme, I’d suggest turning on the separate mobile stylesheet, under Appearance > Mobile. This will display the site in a mobile-friendly format. Learn more.

    Just let me know if you need further help.

    #162636

    XOR LX

    Thanks a lot. I appreciate your reply and I will look at making the necessary changes.

    Can you just clarify that what you describe is consistent with what I am experiencing now, after investigating further? For example, right now I have just clicked on one of my blogposts to find that all the bold text is now invisible. What is happening here? This has also occurred on occasion with the content of tags and also with coloured text. Standard text seems to be unaffected, however.

    Changing (i.e. decreasing) the zoom level remedies this situation, but this is obviously not ideal. Not least for me as I have quite poor eyesight and a zoom level of 150% is not in any case a huge increase, especially when, at 100%, Newsy is not the easiest of Themes to read.

    I would very much appreciate your help on this issue. I had no such issues with my previous (free) Theme.

    Regards

    #162637

    XOR LX

    Edit: I have now also noticed that, in some cases (coloured text within pre tags, for example), even zooming does not remedy the issue that the text in question has completely disappeared.

    Is this issue fixable? If not, how do I go about claiming a refund?

    Regards

    • This reply was modified 5 years, 9 months ago by  XOR LX.
    #162639

    Kathryn P.
    Happiness Engineer

    For example, right now I have just clicked on one of my blogposts to find that all the bold text is now invisible.

    That definitely shouldn’t be happening, so it would be good if I could have a look directly. Could you link to the specific post or tag where you’re seeing invisible text? I spot-checked a number of your posts and pages but the text was visible everywhere. A few links would be helpful so I can take a look. Thanks!

    #162640

    XOR LX

    Hi.

    Thanks for the prompt reply.

    http://excelxor.com/2014/12/19/advanced-formula-challenge-10-results-and-discussion/

    Right now, if you find the text “the 8th row in the above matrix:” in the above post, the pre tag block below that, the contents of which should display (and were previously displaying) as:

    {0,0,2,0,3,2,1,0,8,8}

    to me appears without the zeroes (which are formatted as red text, the rest being standard, i.e. black).

    Regards

    #162641

    Kathryn P.
    Happiness Engineer

    While I would definitely like to help troubleshoot the issue you’re having, all premium themes are refundable for up to 30 days after purchase under Store > My Upgrades:

    https://excelxor.wordpress.com/wp-admin/paid-upgrades.php?page=my-upgrades

    Just click the “Cancel and Refund” link.

    #162642

    Kathryn P.
    Happiness Engineer

    Hmm – I’m seeing the zeroes in red, here’s a screenshot:

    Advanced Formula Challenge 10 Results and Discussion EXCELXOR

    Could you let me know what operating system (i.e. Windows 8.1) and browser/version (i.e. Chrome 39) you’re using so I can try to replicate it?

    #162643

    XOR LX

    That’s the strange thing. Sometimes I see it too, but not always. And the bold font issue was there as well, until I played about with the zoom levels.

    I’m using:

    Microsoft Windows XP Professional
    Version 2002
    Service Pack 3

    and:

    Chrome version 39.0.2171.95

    Regards

    #162644

    XOR LX

    Ah, wait! Another thing – why is it that the pre tag boxes in your screenshot aren’t wrapped?

    Can I post a screenshot here of what I see for that same page?

    Regards

    #162645

    Kathryn P.
    Happiness Engineer

    Sure, you can post a screenshot if you upload it – in a graphic format like JPG, PNG, or PDF – in your Media Library I’ll be able to see it.

    #162646

    XOR LX

    This is even worse news! It’s fundamental to my posts that these pre tag blocks are wrapped! And, because they are as I see them, I’ve always assumed that they are to everyone! No wonder some of my readers have complained about that (which I didn’t really understand).

    Regards

    #162647

    XOR LX

    Thanks.

    I think this is correct:

    Regards

    #162648

    Kathryn P.
    Happiness Engineer

    Is there a reason why you need the pre tag specifically? If you let me know what you’re trying to achieve I can suggest an alternative. pre is usually meant for something very specific:

    https://developer.mozilla.org/en-US/docs/Web/HTML/Element/pre

    Also, instead of repeating your inline styles every time you use a tag or class, you can put it in your custom CSS instead. A huge time-saver. :-)

    For example, let’s say you do want to use pre for something specific. If you add something like this to your custom CSS under Appearance > Customize > CSS, you’ll avoid having to put the styles in your post editor every time you use the tag.

    pre {
      padding:.1em .5em .3em .7em;
      border:2px solid #ccc;
    }
    #162649

    XOR LX

    But can you first clarify why the tags would be viewed differently in different browsers?

    They are necessary since they contain a lot of text which would otherwise be interpreted as HTML code. I currently use:

    <pre style=”font-size:13px;line-height:1.6em;padding:.1em .5em .3em .7em;width:455px;word-wrap:break-word;border:2px solid #ccc;”>”INSERT STUFF HERE”

    Regards

    #162650

    XOR LX

    The closing /pre tag got missed off that last post.

    Regards

    #162651

    XOR LX

    I should also have mentioned that that screenshot was taken with a zoom level of 125% in my browser.

    Regards

    #162652

    Kathryn P.
    Happiness Engineer

    But can you first clarify why the tags would be viewed differently in different browsers?

    Good question. :-) That’s unfortunately the nature of HTML and CSS – browsers sometimes don’t render the same code in the same way.

    My suspicion here is that the CSS property word-wrap, which “Allows lines to be broken within words if an otherwise unbreakable string is too long to fit.” is not applied the same way in Chrome and Firefox. (My above screenshot was from Firefox 34). If you look it up at caniuse.com – an excellent site – you’ll see that Firefox and Internet Explorer only partially support it, while Chrome fully supports it:

    http://caniuse.com/#search=word-wrap

    It also says: “Partial support refers to requiring the legacy name “word-wrap” (rather than overflow-wrap) to work.”

    I see here that word-wrap has now been superceded by the newer overflow-wrap, which you could try instead:

    https://developer.mozilla.org/en-US/docs/Web/CSS/word-wrap

    #162653

    XOR LX

    Thanks. I’ll try replacing all of my cases of “word-wrap” with “overflow-wrap”, though I imagine there’s no quick way to do that en masse for all my posts?

    That may solve the wrap issue. Do you have any ideas as to what’s happening with the missing text, as per my screenshot?

    Regards

    #162654

    Kathryn P.
    Happiness Engineer

    Thanks. I’ll try replacing all of my cases of “word-wrap” with “overflow-wrap”, though I imagine there’s no quick way to do that en masse for all my posts?

    There would be a quick way if you separated out the CSS and put it into the CSS editor as I suggested above, instead of inline on each pre tag. This might be a good opportunity to go ahead and do that, at least with a few tags to start off.

    I took a look at your sample page in a virtual machine running Windows XP and Chrome 39. I still see the zeroes in red:

    Dashboard

    (ignore the “squished” effect – that’s just a glitch in our forum software)

    Could you try turning off all Chrome extensions to see if something might be interfering?

    http://support.google.com/chrome/bin/answer.py?hl=en&answer=187443

    Scroll down to the section called “Temporarily disable extensions.”

Viewing 20 posts - 1 through 20 (of 27 total)

The topic ‘Minimum Window Width Required to View Content’ is closed to new replies.